Microsoft Speech Service Degradation Impacting IVR

Incident Report for Kore.ai Inc

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 12:26 IST

Identified

An issue with Microsoft ASR confidence scores in the East region has been reported by multiple customers using our BankAI solution over IVR.

This has been identified as an issue from Microsoft’s end. During our working session, the Microsoft support team acknowledged the problem and is actively working on a fix, although it has not yet been reflected on their status page.

For BankAI customers, as an interim mitigation, we have i implemented workaround by handling the minimum confidence score.

Other Kore customers using Microsoft ASR in the US East region and relying on confidence scores may also experience similar issues.
A possible workaround can be to reduce the minimum confidence score threshold (e.g., set it to 0.01) to allow calls to proceed and minimize impact.
Posted Apr 24, 2026 - 01:01 IST
This incident affected: Third-party services we use (Microsoft Azure ASR/TTS).