US Region - Degraded performance of analytics dashboard observed on XO11.

Incident Report for Kore.ai Inc

Resolved

This incident has been resolved.
Posted May 21, 2026 - 23:51 IST

Monitoring

A fix has been implemented and we are monitoring the system behaviour.
Posted May 21, 2026 - 23:33 IST

Identified

The issue has been identified and a fix is being implemented.
Posted May 21, 2026 - 23:21 IST

Investigating

We are currently investigating the issue.
Posted May 21, 2026 - 23:01 IST
This incident affected: Region - USA (Bot Builder).