Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 24, 2026 - 10:30 IST
Scheduled
This is to inform our ARTEMIS users that we will be deploying v1.6.6 Hotfix in DE PROD during this time.
SUMMARY:
This release improves language handling for real-time voice transcription using Gemini Live. Agents can now supply the intended interaction language directly through the conversation flow, so transcription applies the correct language without requiring a separately configured multilingual profile on the voice channel.
What's improving?
- More reliable language detection for both caller and agent audio during live calls. - Mid-call language changes are now handled cleanly, with safeguards to prevent stale or partial transitions. - The language-switch setting has been streamlined out of the Studio channel-connection screen; the same control is now managed within the voice pipeline configuration.
Impact areas:
- Existing voice flows continue to work as before; this is a reliability and configuration improvement, not a behavioral change to configured calls. - If you previously set the Gemini language-switch option on the channel-connection UI, that control now lives in the pipeline voice settings — no functionality is lost. The agent-developer guide has been updated accordingly. - No customer action is required unless you actively manage language-switch configuration, in which case refer to the updated guide.
During this maintenance window, if you observe any sporadic issues, please refer to our Release Community Guidance for additional information.
We appreciate your continued understanding and partnership as we work to ensure accurate and up-to-date release information.
Posted Sep 24, 2026 - 10:27 IST
This scheduled maintenance affected: Artemis - DE (Agents Studio, Agents Runtime, Workflows, Search AI, Insights, Evals).