Investigating Performance Degradation Issues on UAE Instance (XO 10 & XO 11)

Incident Report for Kore.ai Inc

Resolved

The service provider has confirmed that restoration efforts are currently in progress and are expected to take several hours.
Although there is no impact on end users at Kore, we have proactively redirected traffic to a different region to prevent any unforeseen discrepancies.

Kore Team will continue to monitor the situation closely in coordination with the service provider.

This incident thread will now be closed. Should any additional issues arise in the meantime, a new incident will be opened and communicated promptly.
Posted Mar 01, 2026 - 22:07 IST

Monitoring

At this time, we have validated our bots and are not observing any latency.

The service provider has reported a localized power issue affecting one Availability Zone (mec1-az2) in the ME-CENTRAL-1 region, causing temporary connectivity issues and elevated error rates for certain resources. Other Availability Zones remain unaffected, and traffic has been shifted where possible. Restoration efforts are ongoing, with recovery expected to take several hours.

We will continue to closely monitor the situation and provide further updates as needed.

Service Provider Status Page: https://health.aws.amazon.com/health/status
Posted Mar 01, 2026 - 20:34 IST

Investigating

We are currently experiencing performance degradation on our UAE instance due to a disruption from our service provider.

Our team is actively working with the provider to resolve the issue as quickly as possible. We will share further updates as soon as more information becomes available.

Thank you for your patience.
Posted Mar 01, 2026 - 19:14 IST
This incident affected: Region - Middle East (UAE) (Bot Uptime, APIs, Bot Builder).