The support portal https://support.kore.ai is experiencing issues

Incident Report for Kore.ai Inc

Resolved

The issue with the support portal has been resolved now. Thank you for your patience.
Posted May 30, 2025 - 05:56 IST

Investigating

Dear users,

Our support portal is experiencing issues. Users are unable to log in across all regions. We are working with our vendor to remediate it as soon as possible.

Temporarily, we have re-enabled email ticketing. Please send an email to support@kore.zendesk.com to create a ticket with us. You will receive an automated acknowledgement when a ticket is created successfully. We deeply apologize for any inconvenience caused.
Posted May 30, 2025 - 05:34 IST
This incident affected: Third-party services we use (Zendesk).